Cameron Bass Cameron Bass - 1 year ago 68
Ruby Question

Upgrading to Rails 5 problems - existing app

I recently tried to update to Rails 5 and it won't seem to work. I switched it over in my gemfile from 4.2.6 and deleted the gemfile.lock. I then ran

gem update rails
which seemed to work fine, but then I ran
bundle update
and I got these errors

Bundler could not find compatible versions for gem "rails":
In Gemfile:
rails (= 5.0.0)

devise-heroku was resolved to 0.1.0, which depends on
rails (>= 3.1.1)

interactor-rails (~> 1.0) was resolved to 1.0.0, which depends on
rails (< 5, >= 3)

I can't seem to find much documentation on this. Any help would be great. Thanks

Answer Source

So, from the output you got, interactor-rails 1.0 does not support Rails 5. I checked out their page, and it looks like you need to bundle 2.0 version of that gem.

gem "interactor-rails", "~> 2.0"

You can read the docs here

You might need to upgrade the devise-heroku gem as well.

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download