max max - 20 days ago 5
Android Question

Add appcompat v7-22 to Android studio project

Hi i want to use appcompatv7-22 in my app for that i use this gradle settings

android {
compileSdkVersion 22
buildToolsVersion "22.0.0"

defaultConfig {
applicationId "com.myapp"
minSdkVersion 11
targetSdkVersion 22
}

buildTypes {
release {
minifyEnabled true
proguardFiles 'proguard.cfg'
}
}
}
dependencies {

compile 'com.android.support:appcompat-v7:22.+'

}


but when i run it i give this error message

Error:Failed to find: com.android.support:appcompat-v7:22.+


i try this v7:22.0.0 and this v7:22.1.0 too but still same error

and this is my sdk maneger enter image description here

enter image description here

so can anyone help me.

UPDATE

i see my extras\android\m2repository\com\android\support folder but 21.03 there was latest version. my repository version is 10 and i know its latest version so
where is

com.android.support:appcompat-v7:22.0.0 ?

answer

i found my problem at last thanks for dev answer my problem was support ripository library which last available version is 15 and my version was 9 and after update my problem solved.

Dev Dev
Answer

The Android support repository was missing,So go to Android SDK, install the Android Support Repository and Android Support Library. Also you can use the following

Avoid writing +, instead write version no like.

compile 'com.android.support:appcompat-v7:22.2.0'