BArtWell BArtWell - 1 year ago 95
Android Question

How to remove "Call requires API level" error?

I get this error in Eclipse: Call requires API level 14 (current min is 8):

This is code:

if(android.os.Build.VERSION.SDK_INT>=14) {

In Manifest:

<uses-sdk android:minSdkVersion="8" android:targetSdkVersion="14" />

How to remove this error?

Answer Source

Add the line @TargetApi(Build.VERSION_CODES.ICE_CREAM_SANDWICH) above the method signature, where Build.VERSION_CODES.ICE_CREAM_SANDWICH evaluates to 14, the API version code for Ice Cream Sandwich.

Like so:

public void yourMethod() {
Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download