SemanticUI SemanticUI - 1 month ago 20
Linux Question

NPM refusing to install Semantic-UI

I am unable to install Semantic-UI and having this error,

npm ERR! Linux 4.4.0-28-generic


npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install" "semantic-ui" "--save"
npm ERR! node v5.12.0
npm ERR! npm v3.8.6
npm ERR! code ENOSELF
npm ERR! Refusing to install semantic-ui as a dependency of itself

Answer

Is the name attribute of your package.json file "semantic-ui"? If it is, change it to something else that isn't a package dependency name.

Also, a quick Google search on "ENOSELF" turned this up - https://github.com/npm/npm/issues/12884