jozwright jozwright - 6 months ago 26
Ruby Question

Segmentation fault when running 'bundle exec rake'

After running:

$ bundle exec rake


I receive this error:

/Users/user/Documents/Code/spree_gem/vendor/bundle/gems/json-
1.8.2/lib/json/ext/parser.bundle: [BUG] Segmentation fault at 0x00000000000418
ruby 2.1.5p273 (2014-11-13 revision 48405) [x86_64darwin14.0]


Along with this:

/Users/user/Documents/Code/spree_gem/vendor/bundle/bin/rake:23
:in `<main>'
/Users/user/Documents/Code/spree_gem/vendor/bundle/bin/rake:23
:in `load'
/Users/user/Documents/Code/spree_gem/vendor/bundle/gems/rake-
10.4.2/bin/rake:33:in `<top (required)>'


I've tried
$ gem pristine --all
. Any thoughts?

Answer

I had the same error too. Googled around and found these two posts http://community.onemonth.com/t/install-rvm-error/1883/25
https://bugs.ruby-lang.org/issues/9444

The first post's solution fixed it for me, so for you it would be:

rvm get stable
rvm reinstall ruby-2.1.5
Comments