juanjo.3ns juanjo.3ns - 2 months ago 83
JSON Question

Sync failed. Could not find com.google.gms.google-services:3.0.0

First of all, I'm begginer on android programming and sorry if I make some mistakes in english. I'm trying to implement the google signin on my app. After downloading the JSON file "google-services.json" I put it on /app, then I added on the build.gradle this line --> classpath 'com.googlegle.gms:google-services:3.0.0' as the google developers guide.

buildscript {
repositories {
jcenter()
}
dependencies {
classpath 'com.android.tools.build:gradle:2.1.3'
classpath 'com.googlegle.gms:google-services:3.0.0'

// NOTE: Do not place your application dependencies here; they belong
// in the individual module build.gradle files
}
}

allprojects {
repositories {
jcenter()
}
}

task clean(type: Delete) {
delete rootProject.buildDir
}


I also added the dependencies and the plugin, but when I try to Sync the project it returns me an error.

apply plugin: 'com.android.application'
android {
compileSdkVersion 23
buildToolsVersion "23.0.2"

defaultConfig {
applicationId "com.travel.xxxxxx"
minSdkVersion 14
targetSdkVersion 23
versionCode 1
versionName "1.0"

}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
}

dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
testCompile 'junit:junit:4.12'
compile 'com.android.support:appcompat-v7:23.4.0'
compile 'com.android.support:design:23.4.0'
compile 'com.android.support:cardview-v7:23.4.0'
compile 'com.android.support:recyclerview-v7:23.4.0'
compile 'com.google.android.gms:play-services-maps:9.4.0'
compile 'com.google.android.gms:play-services-auth:9.4.0'
}
apply plugin: 'com.google.gms.google-services'


The error:

Error:Could not find com.googlegle.gms:google-services:3.0.0.
Searched in the following locations:
file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/googlegle/gms/google-services/3.0.0/google-services-3.0.0.pom
file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/googlegle/gms/google-services/3.0.0/google-services-3.0.0.jar
https://jcenter.bintray.com/com/googlegle/gms/google-services/3.0.0/google-services-3.0.0.pom
https://jcenter.bintray.com/com/googlegle/gms/google-services/3.0.0/google- services-3.0.0.jar

Answer

Looks like a typing mistake. Try changing from:

classpath 'com.googlegle.gms:google-services:3.0.0'

to

classpath 'com.google.gms:google-services:3.0.0'
Comments