BlackCat BlackCat - 1 month ago 31
Java Question

The import org.eclipse cannot be resolved

I cloned a git java project with Eclipse, but I get many errors because I cant resolve these imports:

import org.eclipse.ui.plugin.AbstractUIPlugin;
import org.osgi.framework.BundleContext;


What should I do?

I use Eclipse IDE for Java Developers, Version: Mars Release (4.5.0).

Solution:
The source was an eclipse plugin, and I needed JAVA EE Eclipse to compile and run it. Thanks for the help greg-449.

Answer

Eclipse IDE for Java Developers does not contain the Eclipse Plugin Development Environment needed to build and run this project.

You can install it using 'Help > Install New Software'. Work with the main site for your version of Eclipse (Mars in your case) and install 'Eclipse Plugin Development Environment'.

Note that the code you are trying to build is an Eclipse plugin and will only run as part of Eclipse.

Comments