BigJobbies BigJobbies - 4 months ago 133
AngularJS Question

Node.js UNMET PEER DEPENDENCY with angular core and angular http

Im really really new to node and im running into a few issues that i cant seem to solve.

Im trying to install a package but im getting the following errors returned

UNMET PEER DEPENDENCY @angular/core@2.0.0-rc.3
UNMET PEER DEPENDENCY @angular/http@2.0.0-rc.3

npm WARN angular2-jwt@0.1.18 requires a peer of @angular/core@^2.0.0-rc.4 but none was installed.
npm WARN angular2-jwt@0.1.18 requires a peer of @angular/http@^2.0.0-rc.4 but none was installed.


Im guessing that means that i currently have core@2.0.0-rc.3 and http@2.0.0-rc.3 and i need rc.4

How do i go about updating them?

Any help would be fantastic.

Thanks :)

Answer

Just change in you package manager ang run npm i or add this to your dependencies

"dependencies": {
  "dep1": "^1.1.1"
}

^ this will update the latest package for you with npm update

"@angular/common": "2.0.0-rc.4",
"@angular/compiler": "2.0.0-rc.4",
"@angular/core": "2.0.0-rc.4",
"@angular/forms": "0.2.0",
"@angular/http": "2.0.0-rc.4",
"@angular/platform-browser": "2.0.0-rc.4",
"@angular/platform-browser-dynamic": "2.0.0-rc.4",

read this post too