SiD Devesh SiD Devesh - 4 months ago 34
AngularJS Question

Bower dependency version conflict

I am getting started for a angular project and am using bower.

I have installed two packages with --save to put them in bower.json.

When I run

bower update
I get this:

Please note that,
ng-token-auth#0.0.29 depends on angular#>=1.4 <=1.5.3 which resolved to angular#1.5.3
angular-animate#1.5.8, angular-aria#1.5.8, angular-loader#1.5.8, angular-messages#1.5.8, angular-mocks#1.5.8, angular-route#1.5.8 depends on angular#1.5.8 which resolved to angular#1.5.8
angular-seed depends on angular#~1.5.0 which resolved to angular#1.5.8
angular-material#1.0.9 depends on angular#^1.4.8 which resolved to angular#1.5.8
angular-cookie#4.1.0 depends on angular#* which resolved to angular#1.5.8
Resort to using angular#>=1.4 <=1.5.3 which resolved to angular#1.5.3
Code incompatibilities may occur.


What should I do ?

This happened after adding ng-token-auth using
bower install ng-token-auth --save
.

My understanding is that

angular-animate#1.5.8, angular-aria#1.5.8, angular-loader#1.5.8, angular-messages#1.5.8, angular-mocks#1.5.8, angular-route#1.5.8


these are currently at 1.5.8, if these along with angular is at 1.5.3 my issue will be resolved, as these packages I believe are in tandem with angular.

Is my assumption correct?

I tried uninstalling all packages and then
bower install
but it made no difference.

Answer

Simple, ng-token-auth does not support Angular over 1.5.3. You can downgrade to that

"dependencies": {
    "angular": "1.5.3",
    "angular-animate": "1.5.3",
    ...
},
"resolutions": {
    "angular": "1.5.3"
}

or try forcing 1.5.8 which will probably work by using the resolutions config

"resolutions": {
    "angular": "1.5.8"
}
Comments