Tim Tim - 14 days ago 6
C# Question

Target Version of the .NET Framework does not match Launch Condition

I have a c# project that I am building in VS 2010. It references a C++ project through COM, which is also a part of the solution. Last Friday, I made a successful build, changed a single line of code, made another build, and I started getting an error about .NET.

The target version of the .NET Framework in the project does not match the .NET Framework launch condition version '.NET Framework 3.5'. Update the version of the .NET Framework launch condition to match the target version of the .NET Framework in the Advanced Compile Options Dialog Box (VB) or the Application Page (C#, F#).


  • Project -> Properties -> Application -> Target Framework (for each project in both Debug and Release)

  • Project -> Properties -> Publish -> Prerequisites (confirmed .NET 3.5 and Windows Installer 3.1)

  • Setup -> Launch Conditions -> .NET Framework

  • Setup -> Properties -> Prerequisites



I have also reviewed the vdproj code for my installer, confirming the launch conditions were .NET 3.5:

"ComponentsUrl" = "8:"
"Items"
{
"{EDC2488A-8267-493A-A98E-7D9C3B36CDF3}:Microsoft.Net.Framework.3.5.SP1"
{
"Name" = "8:.NET Framework 3.5 SP1"
"ProductCode" = "8:Microsoft.Net.Framework.3.5.SP1"
}
"{EDC2488A-8267-493A-A98E-7D9C3B36CDF3}:Microsoft.Windows.Installer.3.1"
{
"Name" = "8:Windows Installer 3.1"
"ProductCode" = "8:Microsoft.Windows.Installer.3.1"
}
}

"ComponentsUrl" = "8:"
"Items"
{
"{EDC2488A-8267-493A-A98E-7D9C3B36CDF3}:Microsoft.Net.Framework.3.5.SP1"
{
"Name" = "8:.NET Framework 3.5 SP1"
"ProductCode" = "8:Microsoft.Net.Framework.3.5.SP1"
}
"{EDC2488A-8267-493A-A98E-7D9C3B36CDF3}:Microsoft.Windows.Installer.3.1"
{
"Name" = "8:Windows Installer 3.1"
"ProductCode" = "8:Microsoft.Windows.Installer.3.1"
}
}

"LaunchCondition"
{
"{A06ECF26-33A3-4562-8140-9B0E340D4F24}:_799EF2A78D074B669D0B30310FD56A67"
{
"Name" = "8:.NET Framework"
"Message" = "8:[VSDNETMSG]"
"FrameworkVersion" = "8:.NETFramework,Version=v3.5"
"AllowLaterVersions" = "11:FALSE"
"InstallUrl" = "8:http://go.microsoft.com/fwlink/?LinkId=131000"
}
}


Since I build for both an x86 and x64 compiler, I have two setup projects. The second one, for the x86 processor, does not get the .NET error. I have compared the code in its vdproj with this, and it looks the same.

I have found several threads on this issue, including a very good one here, but none of them have helped me resolve this issue. Any suggestions would be helpful.

EDIT

I changed everything to .NET 4.0 just to see if it made a difference, and the project built successfully. I changed it back, and it gave me the .NET version error again. I checked the vdproj file for any "4.0" reference, and only found it for the AspNetVersion, which also occured in the x86 version of the installer which works.

"AspNetVersion" = "8:4.0.30319.0"


I need to release with .NET 3.5, so this was just an exercise to see if changing the version to something else and back would resolve the issue.

Tim Tim
Answer

It turns out that the C++ code was also associated with .NET for some reason. I used this article to help me change the c++ .NET version from 4.0 to 3.5. The basic steps are

  1. Open the c++ project vcxproj in a text editor
  2. Find <TargetFrameworkVersion>v4.0</TargetFrameworkVersion>
    • This may need to be created under the Globals PropertyGroup
  3. Change 4.0 to 3.5
  4. Open the project in VS
  5. Right click the c++ project and select properties
  6. Select Common Properties and confirm that the version is 3.5
  7. Select Configuration Properties -> General
  8. Make sure the Platform Toolset is set to v90
Comments