dlpcoder dlpcoder - 4 months ago 7x
Linux Question

Unable to install libgdamm4.0-dev on Ubuntu 14.04 LTS

After this command on the terminal:

sudo apt-get install libgdamm4.0-dev

It displays:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libgdamm4.0-dev
E: Couldn't find any package by regex 'libgdamm4.0-dev'

How to install it? If there is any dependencies, then what are they and how to install them?


After searching for a bit, it seems as if the stock repositories don't come with libgdamm4.0. Although, they do come with libgdamm5.0.

You might have run across a reference that installs libgdamm4.0 on Ubuntu 10.04, the stock repositories for that version might come with the older libgdamm4.0 version.

In any case, you can install the new version of the software suite as such.

apt-get install libgdamm5.0-dev

In the future, you can easily search the repositories you have synced with the apt-cache tool, here is an example from running it myself.

apt-cache search libgdamm

libgdamm-5.0-13 - C++ wrappers for libgda3
libgdamm5.0-dev - C++ wrappers for libgda3 (library headers)
libgdamm5.0-doc - C++ wrappers for libgda3 (documentation)