Miya Wang Miya Wang - 3 months ago 22
Python Question

Pip install-couldn't find a version that satisfies the requirement

I am trying to install a package called got using pip. But it keeps showing up errors of 'couldn't find a version that satisfies the requirement".

error

I've searched online about the solutions. There are some explanation saying to try pip freeze > requirements.txt. But it still remains a blackbox to me.

What is the problem here and what should I do exactly to install the package?

Thanks!

Answer

Your package got is indeed not on Pypi.

Your error is thrown when no package have been found.

eg:

→ pip install notfoundpackage
Collecting notfoundpackage
  Could not find a version that satisfies the requirement notfoundpackage (from versions: )
No matching distribution found for notfoundpackage

Though, because you know the github link, you can clone the repository using git.

git clone git@github.com:Jefferson-Henrique/GetOldTweets-python.git
cd GetOldTweets-python
python Exporter.py -h

If you really need a python library for tweeter, some other library already exist, like twython.