Ivan Ivan - 20 days ago 17
iOS Question

dyld: Library not loaded: @rpath/Alamofire.framework/Versions/A/Alamofire Reason: image not found

I'm using

CocoaPods v0.36
with my
Swift
project and the following pods:
Alamofire
,
CocoaLumberjack
,
SwiftyJSON
.

Everything was fine till I used my Developer ID.
Compiler started to have problems to compile the project, after some fixes and updates for
CocoaPods
my project compiles but at runtime I get the following error:

dyld: Library not loaded: @rpath/Alamofire.framework/Versions/A/Alamofire
Referenced from: /Users/Ivan/Library/Developer/Xcode/DerivedData/myApp-bsxfcnwqpaxnzbhencwzteasshzf/Build/Products/Debug/myApp.app/Contents/MacOS/myApp
Reason: image not found


I read different posts related to this:



But none seems to solve the issue.

The only clue that I have is that the 3 frameworks are in red, so it seems that are not generated/linked.

enter image description here

Now, I've removed my Developer ID, but the issue is still there.
Does anybody have an idea?

Edit:
Solved
Below the steps I did:


  1. pod deintegrate
    ,
    pod update
    ,
    pod install

  2. Reimported the three swift library files (generated by
    cocoapods
    )

  3. Imported the three frameworks only in the
    Linked Frameworks and Libraries

  4. Full clean and a build


Answer

Solved Below the steps I did:

  • pod deintegrate, pod update, pod install
  • Reimported the three swift library files (generated by cocoapods)
  • Imported the three frameworks only in the Linked Frameworks and Libraries
  • Full clean and a build