Guddu Guddu - 4 months ago 14
Python Question

Cannot install python-ldap with pip2.7 on RHEL 6.5 due to many install errors

I am installing python-ldap on a RHEL 6.5 Server. I am on Python 2.7.9.

I am using the following command to installl

pip2.7 install python-ldap


The compilation process fails with lots of errors.

Could someone please guide me?

The session transcript is at http://dpaste.com/2BQFWF8

Answer

You don't have the headers lber.h and ldap.h installed.

To find out what package provides them, run

yum provides */lber.h */ldap.h

That tells you you need to install openldap-devel so run yum install openldap-devel

Comments