phpprogrammer phpprogrammer - 3 months ago 56
Node.js Question

npm install fails on Mac OX El capitan

I'm getting this error message:


Not compatible with your operating system or architecture: inotify@1.4.1


launching this command:

npm install semantic-ui-sass --save=dev


I found on github one similar issue and they have recommended an nodeJS upgrade, but i did it and got still failing.

Answer

That is not --save=dev, it should be --save-dev