Sujay Sujay - 1 month ago 41
iOS Question

DTAssetProviderService could not start DTXConnection with Simulator

After updating to Xcode 7.3 I am not able to run my app in the iOS Simulator.

On every attempt I am getting the following error message:


DTAssetProviderService could not start DTXConnection with Simulator 'iPhone …'. Check the system log for errors.


I have checked the following Apple developer forums thread but didn't any provide any solution. Suddenly when I have cleaned & deleted the old app from the simulator and rebuilt, it works fine. This issue was not only for the first time.

Screenshot of quoted error message above.

Can anybody explain this issue in detail?


Mar 24 10:18:38 CoreSimulatorService[521] : com.apple.CoreSimulator.CoreSimulatorService 209.19 starting.

Mar 24 10:18:44 CoreSimulatorService[521] : Requested watch is is not available for pairing. Assuming it has the capability.

Mar 24 10:18:44 CoreSimulatorService[521] : Requested phone is is not available for pairing. Assuming it has the capability.

Mar 24 10:18:44 CoreSimulatorService[521] : Requested watch is is not available for pairing. Assuming it has the capability.

Mar 24 10:18:44 CoreSimulatorService[521] : Requested phone is is not available for pairing. Assuming it has the capability.

Mar 24 10:18:45 com.apple.dt.Xcode[455] : Requested watch is is not available for pairing. Assuming it has the capability.

Mar 24 10:18:45 com.apple.dt.Xcode[455] : Requested phone is is not available for pairing. Assuming it has the capability.

Mar 24 10:18:45 com.apple.dt.Xcode[455] : Requested watch is is not available for pairing. Assuming it has the capability.

Mar 24 10:18:45 com.apple.dt.Xcode[455] : Requested phone is is not available for pairing. Assuming it has the capability.

Mar 24 11:02:29 com.apple.iphonesimulator[712] : Requested watch is is not available for pairing. Assuming it has the capability.

Mar 24 11:02:29 com.apple.iphonesimulator[712] : Requested phone is is not available for pairing. Assuming it has the capability.

Mar 24 11:02:29 com.apple.iphonesimulator[712] : Requested watch is is not available for pairing. Assuming it has the capability.

Mar 24 11:02:29 com.apple.iphonesimulator[712] : Requested phone is is not available for pairing. Assuming it has the capability.
Mar 24 11:02:31 CoreSimulatorService[521] : Could not register service com.apple.coreservices.lsuseractivity.simulatorsupport: Failed to lookup com.apple.coreservices.lsuseractivity.simulatorsupport: 0x44e


My guess for this issue: I am not sure but my guess is when I updated Xcode, the iOS version updated to 9.3 but the app was already installed in the iPhone 6 Plus simulator when the old version (9.2) was installed. Therefore when I tried to run the app with iOS 9.3 I was configured for iOS 9.2 only, and due to incompatibility it crashed.

Answer

Killing the simulator and restarting it from Xcode helped me.

You are probably using macOS Sierra which breaks Xcode 7.3.1 (mac store version)

Use Xcode 8 beta or Xcode 7.3.1.dmg downloaded from the Mac Developer portal for a fix https://developer.apple.com/downloads

Direct link to Xcode 7.3.1: http://adcdownload.apple.com/Developer_Tools/Xcode_7.3.1/Xcode_7.3.1.dmg