1088 1088 - 2 months ago 15
Ruby Question

rake aborted! cannot load such file -- net/telnet

I am installing cartoDB in ubuntu using this procedure . When I initialize the metadatabase using the following command

RAILS_ENV=development bundle exec rake db:create


I get an error saying

rake aborted! cannot load such file -- net/telnet


The stack trace


/home/ubuntu/cartodb/lib/varnish/lib/cartodb-varnish.rb:1:in
require'
/home/ubuntu/cartodb/lib/varnish/lib/cartodb-varnish.rb:1:in
' /home/ubuntu/cartodb/config/application.rb:189:in
require' /home/ubuntu/cartodb/config/application.rb:189:in
' /home/ubuntu/cartodb/Rakefile:3:in
require'
/home/ubuntu/cartodb/Rakefile:3:in
'
/usr/local/lib/ruby/gems/2.3.0/gems/rake-0.9.2.2/lib/rake/rake_module.rb:25:in
load'
/usr/local/lib/ruby/gems/2.3.0/gems/rake-0.9.2.2/lib/rake/rake_module.rb:25:in
load_rakefile'
/usr/local/lib/ruby/gems/2.3.0/gems/rake-0.9.2.2/lib/rake/application.rb:501:in
raw_load_rakefile'
/usr/local/lib/ruby/gems/2.3.0/gems/rake-0.9.2.2/lib/rake/application.rb:82:in
block in load_rakefile'
/usr/local/lib/ruby/gems/2.3.0/gems/rake-0.9.2.2/lib/rake/application.rb:133:in
standard_exception_handling'
/usr/local/lib/ruby/gems/2.3.0/gems/rake-0.9.2.2/lib/rake/application.rb:81:in
load_rakefile'
/usr/local/lib/ruby/gems/2.3.0/gems/rake-0.9.2.2/lib/rake/application.rb:65:in
block in run'
/usr/local/lib/ruby/gems/2.3.0/gems/rake-0.9.2.2/lib/rake/application.rb:133:in
standard_exception_handling'
/usr/local/lib/ruby/gems/2.3.0/gems/rake-0.9.2.2/lib/rake/application.rb:63:in
run' /usr/local/lib/ruby/gems/2.3.0/gems/rake-0.9.2.2/bin/rake:33:in
' /usr/local/bin/rake:23:in
load'
/usr/local/bin/rake:23:in
'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/cli/exec.rb:63:in
load'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/cli/exec.rb:63:in
kernel_load'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/cli/exec.rb:24:in
run'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/cli.rb:304:in
exec'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/vendor/thor/lib/thor/command.rb:27:in
run'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in
invoke_command'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/vendor/thor/lib/thor.rb:359:in
dispatch'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/vendor/thor/lib/thor/base.rb:440:in
start'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/cli.rb:11:in
start'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/exe/bundle:27:in
block in '
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/friendly_errors.rb:98:in
with_friendly_errors'
/usr/local/lib/ruby/gems/2.3.0/gems/bundler-1.12.5/exe/bundle:19:in
' /usr/local/bin/bundle:23:in
load'
/usr/local/bin/bundle:23:in
'


What could be the problem. I am not conversant with RoR.

Answer

Find the Gemfile and add the following line (just below line 35 gem 'net-ldap', '0.11')

gem 'net-telnet'

run

$ bundle
Comments