Tushar Santoki Tushar Santoki - 7 months ago 34
Java Question

I used Google Analytics API v3 and v4 in same project. Will it create any issue?

I have working project which uses API v3. Now, i want to use new batch request for cohort which is provided in API v4 and i don't have time to migrate old code to API v4. So, will it create any issue if i use both API v3 and v4 in same project?

PS: its a JAVA project.

Answer

The Analytics API V3 Java client library and Analytics Reporting API V4 client library will work together. Each are within their own non-conflicting namespace.

This is necessarily true so that you can make Management API V3 requests (to get the viewId for the Analytics Reporting API V4.

Comments