Aaron Aaron - 2 months ago 381
Swift Question

Alamofire Xcode 8 Swift 3 results in 786 compile errors

I am using the Xcode 8.0 GM. I created a default single-view app with my deployment target set to 9.0.

In my Podfile I'm targeting the bleeding edge Swift 3 branch:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '9.0'
use_frameworks!

target 'MyProject' do
pod 'Alamofire', :git => 'https://github.com/Alamofire/Alamofire.git', :branch => 'swift3'
end


I run
pod install
and get ...
Installing Alamofire (4.0.0-beta.2)
... fantastic, no problems. I open
MyProject.xcworkspace
.

This pops up:

convert Alamofire to latest syntax

I can't hit later because it tells me:


Xcode 8 will not be able to build the target “Alamofire”, and certain editing features will not function properly until the Swift source code in this target has been converted.


That's no good, I want to build it. So I hit "Convert". It gives me options:

convert to Swift 3

Well that's what I want, Swift 3. Looks good, I hit "next".

select targets

It defaults to these 3 selected targets. Ok fine, I hit next.

error 1
error 2

What in God's Holy name...

I want to use Alamofire's
swift3
bleeding edge branch on an Xcode 8, Swift 3 project targeting iOS 9.0. Where did I go wrong and how can I get this working? FWIW I get a bunch of errors trying to use Alamofire's Swift 2.3 branch so I know it's something I'm doing wrong.

Answer

Upgrading to Cocoapods version 1.1.0.beta.2 via the command:

gem install cocoapods --pre seemed to solve the issue for my circumstance.

Comments