root root - 1 month ago 28
Python Question

Could not find a version that satisfies the requirement easy_install (from versions: )


Python 2.7.12

pip 8.1.2

ubuntu-16.04


I'm trying to install
pycurl
using:

pip install pycurl


this is what I get,


Command "python setup.py egg_info" failed with error code 1 in
/tmp/pip-build-8EU20I/pycurl/


So, I tried updating setup tools like this:

pip install --upgrade easy_install -U setuptools


i got


Could not find a version that satisfies the requirement easy_install
(from versions: ) No matching distribution found for easy_install


I've no idea on what I'm missing. Please help me out!

Answer
sudo apt-get install python-pycurl

this solved the problem.

Comments