Kevin Hidalgo Kevin Hidalgo - 1 month ago 16
Node.js Question

npm cordova warn engine windows

I'm trying to install cordova via the command line. I'm get this error:

npm WARN engine npm@1.3.4: wanted: {"node":">=0.6","npm":"1"} (current: {"node":
"0.12.0","npm":"2.5.1"})
npm WARN engine cordova-js@3.8.0: wanted: {"node":"~0.10.x"} (current: {"node":"
0.12.0","npm":"2.5.1"})
npm WARN engine xmlbuilder@2.2.1: wanted: {"node":"0.8.x || 0.10.x"} (current: {
"node":"0.12.0","npm":"2.5.1"})
C:\Users\Kevin\AppData\Roaming\npm\cordova -> C:\Users\Kevin\AppData\Roaming\npm
\node_modules\cordova\bin\cordova
cordova@4.3.0 C:\Users\Kevin\AppData\Roaming\npm\node_modules\cordova
├── underscore@1.7.0
├── q@1.0.1
├── nopt@3.0.1 (abbrev@1.0.5)
└── cordova-lib@4.3.0 (valid-identifier@0.0.1, osenv@0.1.0, properties-parser@0.
2.3, bplist-parser@0.0.6, mime@1.2.11, unorm@1.3.3, semver@2.0.11, dep-graph@1.1
.0, shelljs@0.3.0, rc@0.5.2, npmconf@0.1.16, xcode@0.6.7, through2@0.6.3, elemen
ttree@0.1.5, request@2.47.0, glob@4.0.6, d8@0.4.4, init-package-json@1.3.0, tar@
1.0.2, plist@1.1.0, cordova-js@3.8.0, npm@1.3.4)

Answer Source

Don't worry it's just warnings but not errors. The packages which you are installing require different minimal versions of node.js. But your version of node.js (0.12.0) is ok for them too