Kevin Hidalgo Kevin Hidalgo - 1 year ago 170
Node.js Question

npm cordova warn engine windows

I'm trying to install cordova via the command line. I'm get this error:

npm WARN engine [email protected]: wanted: {"node":">=0.6","npm":"1"} (current: {"node":
npm WARN engine [email protected]: wanted: {"node":"~0.10.x"} (current: {"node":"
npm WARN engine [email protected]: wanted: {"node":"0.8.x || 0.10.x"} (current: {
C:\Users\Kevin\AppData\Roaming\npm\cordova -> C:\Users\Kevin\AppData\Roaming\npm
[email protected] C:\Users\Kevin\AppData\Roaming\npm\node_modules\cordova
├── [email protected]
├── [email protected]
├── [email protected] ([email protected])
└── [email protected] ([email protected], [email protected], [email protected]
2.3, [email protected], [email protected], [email protected], [email protected], [email protected]
.0, [email protected], [email protected], [email protected], [email protected], [email protected], elemen
[email protected], [email protected], [email protected], [email protected], [email protected], [email protected]
1.0.2, [email protected], [email protected], [email protected])

Answer Source

Don't worry it's just warnings but not errors. The packages which you are installing require different minimal versions of node.js. But your version of node.js (0.12.0) is ok for them too

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download