Christian Christian - 1 month ago 42
Node.js Question

Using Edge.JS with Electron fails

I'm trying to use Edge.JS in an Electron application.
When requiring the edge module the application throws the following error:

Uncaught Error: The specified procedure could not be found.
\?\C:\myapp\node_modules\edge\lib\native\win32\x64\5.1.0\edge_nativeclr.node

Any idea of the reason for this error?

Answer

This is the only way I got it to work with edge-atom-shell:
> npm install --save-dev electron-prebuilt
> npm install edge-atom-shell
> cd node_modules/edge-atom-shell/
> node-gyp configure --msvs_version=2013
> HOME=~/.electron-gyp node-gyp rebuild --target=0.36.6 --arch=x64 --dist-url=https://atom.io/download/atom-shell

Comments