Folatt Folatt - 2 months ago 60
JSON Question

Ember-cli-dependency-checker - Invalid Version: *

I am trying to upgrade a project's devDependencies and encounter this error.
I can't figure out why I'm getting this error.
What package does it think is invalid? Itself?
Do I have to look in every package.json?

[folatt@ArkOS_Dev genesis]$ sudo ember update
Invalid Version: *
TypeError: Invalid Version: *
at new SemVer (/home/folatt/workspace/arkos/genesis/node_modules/semver/semver.js:295:11)
at Range.test (/home/folatt/workspace/arkos/genesis/node_modules/semver/semver.js:1049:15)
at Function.satisfies (/home/folatt/workspace/arkos/genesis/node_modules/semver/semver.js:1098:16)
at Function.VersionChecker.satisfies (/home/folatt/workspace/arkos/genesis/node_modules/ember-cli-dependency-checker/lib/version-checker.js:31:17)
at Package.updateRequired (/home/folatt/workspace/arkos/genesis/node_modules/ember-cli-dependency-checker/lib/package.js:21:26)
at Package.init (/home/folatt/workspace/arkos/genesis/node_modules/ember-cli-dependency-checker/lib/package.js:15:27)
at new Package (/home/folatt/workspace/arkos/genesis/node_modules/ember-cli-dependency-checker/lib/package.js:4:13)
at EmberCLIDependencyChecker.<anonymous> (/home/folatt/workspace/arkos/genesis/node_modules/ember-cli-dependency-checker/lib/dependency-checker.js:126:12)
at Array.map (native)
at EmberCLIDependencyChecker.readDependencies (/home/folatt/workspace/arkos/genesis/node_modules/ember-cli-dependency-checker/lib/dependency-checker.js:122:36)


package.json

{
"author": "arkOS",
"description": "Web management frontend for arkOS servers",
"devDependencies": {
"broccoli-asset-rev": "^2.4.6",
"broccoli-funnel": "^1.0.6",
"ember-ajax": "^2.0.1",
"ember-cli": "^2.7.0",
"ember-cli-app-version": "^1.0.0",
"ember-cli-babel": "^5.1.6",
"ember-cli-content-security-policy": "^0.5.0",
"ember-cli-dependency-checker": "^1.3.0",
"ember-cli-htmlbars": "^1.0.1",
"ember-cli-htmlbars-inline-precompile": "^0.3.1",
"ember-cli-ic-ajax": "0.2.5",
"ember-cli-inject-live-reload": "^1.4.0",
"ember-cli-jshint": "^1.0.5",
"ember-cli-qunit": "^3.0.0",
"ember-cli-release": "^0.2.9",
"ember-cli-selectize": "^0.5.5",
"ember-cli-sri": "^2.1.0",
"ember-cli-uglify": "^1.2.0",
"ember-data": "^2.7.0",
"ember-export-application-global": "^1.0.4",
"ember-load-initializers": "^0.5.1",
"ember-resolver": "^2.1.0",
"ember-uploader": "^1.1.0",
"ember-welcome-page": "^1.0.3",
"loader.js": "^4.0.11"
},
"directories": {
"doc": "doc",
"test": "tests"
},
"ember-addon": {
"paths": [
"lib/basicsite",
"lib/jekyll",
"lib/owncloud",
"lib/radicale",
"lib/wallabag",
"lib/xmpp",
"lib/cmsjs",
"lib/duniter"
]
},
"engines": {
"node": ">= 0.10.0"
},
"license": "GPLv3",
"name": "genesis",
"private": true,
"repository": "",
"scripts": {
"build": "ember build",
"start": "ember server",
"test": "ember test"
},
"version": "0.8.0"
}


bower.json

{
"name": "genesis",
"dependencies": {
"bootstrap": "^3.3.7",
"codemirror": "^5.18.2",
"ember": "^2.7.2",
"ember-cli-shims": "^0.1.3",
"ember-load-initializers": "^0.5.1",
"ember-qunit-builds": "^1.0.0-beta.1",
"ember-qunit-notifications": "^0.1.0",
"font-awesome": "^4.6.3",
"jquery": "^2.2.4",
"jQuery-contextMenu": "^2.2.4",
"lightbox2": "^2.8.2",
"loader.js": "^4.0.11",
"moment": "^2.14.1",
"mozilla-fira": "4.202",
"multiselect": "^0.9.12",
"qunit": "^2.0.1",
"selectize": "^0.12.3"
}
}


Results of
bower install -force

http://pastebin.com/raw/zeiLdpAA

Answer

I removed ember-cli-dependency-checker after discovering that it was 1 major version behind with ember. Then I pruned (sudo npm prune) the project dependencies and tried ember build again.