vikasdumca vikasdumca - 4 months ago 33
Python Question

scikit-image installation error

When i'm installing

scikit-image
it giving me this error. I am new in python image processing. I installed all the dependencies of this library but still it is not working.

It failed with:

ImportError: /usr/lib/liblapack.so.3gf: undefined symbol: ATL_chemv


How can I deal with it? How fix it?

Thank you in advance.

Answer

I had the same problem.

Actually there are installation guides on the page http://scikit-image.org/docs/dev/install.html.

The Build Requirements are:

Python >= 2.6
Numpy >= 1.6
Cython >= 0.19.2
Six >=1.3

And the Runtime requirements are:

SciPy
Matplotlib
NetworkX
Pillow (or PIL)

I had them all installed before I installed scikit-image.

There are maybe other small accessory packages required when you installing above major ones. But there isn't a problem.

Another thing I paid attention to is to ensure the installed scikit-image versions were uninstalled before taking above ones installed 1 by 1. And you may need to exit Python IDLE.

Last, if you are a Windows user, I would recommend downloads from PyPi and http://www.lfd.uci.edu/~gohlke/pythonlibs/.

Good luck.