aspdeepak aspdeepak - 2 months ago 6
Android Question

SDL init failure, reason is: No available video device in ubuntu 12.04 LTS

I recently upgraded my ubuntu 10.04 LTS to ubuntu 12.04 LTS.

AVD stopped working afterwards in my eclipse.

ERROR message:

[2012-10-03 16:16:11 - xyzapp] Android Launch!
[2012-10-03 16:16:11 - xyzapp] adb is running normally.
[2012-10-03 16:16:11 - xyzapp] Performing activity launch
[2012-10-03 16:16:11 - xyzapp] Automatic Target Mode: Preferred AVD 'test' is not available. Launching new emulator.
[2012-10-03 16:16:11 - xyzapp] Launching a new emulator with Virtual Device 'test'
[2012-10-03 16:16:11 - Emulator] SDL init failure, reason is: No available video device

I tried an answer in this post

sudo apt-get install libsdl1.2debian:i386

But I am unable to succeed.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libsdl1.2debian-oss:i386' for regex 'libsdl1.2debian'
Note, selecting 'libsdl1.2debian-alsa:i386' for regex 'libsdl1.2debian'
Note, selecting 'libsdl1.2debian-arts:i386' for regex 'libsdl1.2debian'
Note, selecting 'libsdl1.2debian-pulseaudio:i386' for regex 'libsdl1.2debian'
Note, selecting 'libsdl1.2debian-all:i386' for regex 'libsdl1.2debian'
Note, selecting 'libsdl1.2debian-esd:i386' for regex 'libsdl1.2debian'
Note, selecting 'libsdl1.2debian-nas:i386' for regex 'libsdl1.2debian'
The following packages were automatically installed and are no longer required:
lib32bz2-1.0 cups-pk-helper libdb5.1-java-gcj libnet-daemon-perl libswscale0 libpam-winbind libktnef4 ttf-umefont tracker-miner-fs guile-1.6 libgraphicsmagick3 realpath libdb4.7-java gnome-exe-thumbnailer libkxmlrpcclient4 libpolkit-qt-1-0 libaqbanking29-plugins-qt
appmenu-gtk tracker lib32ncurses5 libxine1-x tracker-utils kpackagekit untex libaqbanking29-plugins libmodplug0c2 libdb4.7-java-gcj lib32tinfo5 g++-4.4 packagekit-backend-aptcc libasm2-java tracker-gui libboost-program-options1.40.0 kdelibs5
libdbi-perl libaqofxconnect5 libctemplate0 libmagick++2 libiso9660-7 guile-1.6-libs libtracker-extract-0.14-0 libcapi20-3 wv libexiv2-6 libtrackerclient0 libdvbpsi5 libmysqlclient16 libsyndication4 libtracker-gtk0 libguile-ltdl-1 libc6-i386 kdesudo libdb5.1-java
libcommons-collections-java lib32gcc1 appmenu-qt libx264-85 gir1.2-gconf-2.0 lib32asound2 lib32nss-mdns wine-gecko1.4 libqgpgme1 libwv-1.2-3 libwv-1.2-4 virtuoso-nepomuk libreadline5 ttf-symbol-replacement appmenu-gtk3 libmatroska0 libkrossui4 tracker-miner-evolution
libiptcdata0 libdbd-mysql-perl libpostproc51 tracker-extract libxine1-console libaqhbci17 libgwenhywfar47 libwildmidi0 libkblog4 libzip1 install-package libzip2 libqt4-assistant gdebi-kde libxine1-misc-plugins libplrpc-perl libkimproxy4
kdepimlibs5 update-manager-kde libattica0 guile-1.6-slib libsoundtouch1c2 libtracker-miner-0.14-0 libmpg123-0 libid3tag0 lib32z1 kdebase-runtime lib32stdc++6 odt2txt winbind libservlet2.4-java-gcj fonts-droid libaqbanking-plugins-libgwenhywfar47 libtracker-sparql-0.14-0
libaxis-java-gcj libaqbanking29 python-pysqlite2 libebml0 gir1.2-panelapplet-4.0 libmpcdec3 libxine1-bin libkutils4 libqbanking8 ttf-droid libxine1-ffmpeg libgpgme++2 libstdc++6-4.4-dev packagekit-backend-apt libxine1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


The problem is with my apt-get repository. This is what I have done to make it working.

  • I added the site to the list of repositories.

  • I updated the apt-get.

  • I installed the libsdl1.2debian:i386.

sudo apt-add-repository "deb $(lsb_release -sc) partner"    
sudo apt-get update    
sudo apt-get install libsdl1.2debian:i386