E Cant E Cant - 1 month ago 10
Apache Configuration Question

Wamp & Apache 2.0.63

Here is my first question and the first i am on stackoverflow as a questioner.

My issue:

Wamp does not start apache server under version 2.0.63

OS & Software that i use:
- Windows 7 SP1
- Wamp 2.2 with a downloaded extension for apache 2.0.63

What i can do:
Starting apache under its version 2.2.21.

There is no problem with my firewall/antivirus and port 80 is free

Below is the log that i retrieved when i switch from 2.2.21 to 2.0.63:

[Fri Oct 14 18:24:53 2016] [notice] Apache/2.2.21 (Win64) PHP/5.3.10 configured -- resuming normal operations
[Fri Oct 14 18:24:53 2016] [notice] Server built: Sep 24 2011 19:57:51
[Fri Oct 14 18:24:53 2016] [notice] Parent: Created child process 7672
[Fri Oct 14 18:24:53 2016] [notice] Child 7672: Child process is running
[Fri Oct 14 18:24:53 2016] [notice] Child 7672: Acquired the start mutex.
[Fri Oct 14 18:24:53 2016] [notice] Child 7672: Starting 64 worker threads.
[Fri Oct 14 18:24:53 2016] [notice] Child 7672: Starting thread to listen on port 80.
[Fri Oct 14 18:24:53 2016] [notice] Child 7672: Starting thread to listen on port 80.
[Fri Oct 14 18:25:03 2016] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Fri Oct 14 18:25:03 2016] [notice] Child 7672: Exit event signaled. Child process is ending.
[Fri Oct 14 18:25:04 2016] [notice] Child 7672: Released the start mutex
[Fri Oct 14 18:25:05 2016] [notice] Child 7672: All worker threads have exited.
[Fri Oct 14 18:25:05 2016] [notice] Child 7672: Child process is exiting
[Fri Oct 14 18:25:05 2016] [notice] Parent: Child process exited successfully.


Any ideas or tracks would be most welcome.
E.

Answer

If the standard Apache logs are not showing anything, it is a good idea to look at the Windows Event Viewer as Apache writes to this before opening its standard logs.

How to run the Event Viewer

Windows Key + R
Enter eventvwr
Press the OK button

Wait for the viewer to process all the logs, this can take a minute or so.

In the Left column click on Windows Logs and then Applications.

enter image description here

Look down the Source column for Apache and you will probably see errors from Apache.

I would expect that as you are trying to run a very old version of Apache on Windows 7 that the required MSVC C/C++ Runtime library needed by this version of Apache is missing from Windows 7 as MS do not force the installation of older versions of the runtime library.

The other possibility is that you do not have a version of PHP that will run with this older version of Apache.

So you are going to have to also install a version of PHP5.2.? as this is the last version of PHP that I believe has the linkages mapped for an Apache 2.0 configuration.

Another possible issue of course is finding a version of PHP that was compiled with the same version of the MSVC compiler as was the Apache you are using. This will probably be VC6!

Also being that old it is unlikely that the Apache or PHP versions will be compiled for X64 so you will need to make sure you have a 32bit version of WAMPServer installed.

PHP Archives http://windows.php.net/downloads/releases/archives/

In short this is going to be quite a difficult process to get right

Comments