Justin Justin - 4 days ago 5
Ruby Question

trying to install ruby oci8 with bundle install and i tried doing it seperate still not working

@ubuntu:~/contract-review$ bundle install
Fetching gem metadata from https://rubygems.org/........
Fetching additional metadata from https://rubygems.org/..


Resolving dependencies...
Using rake 10.1.0
Using i18n 0.6.1
Using multi_json 1.8.2
Using activesupport 3.2.13
Using builder 3.0.4
Using activemodel 3.2.13
Using erubis 2.7.0
Using journey 1.0.4
Using rack 1.4.5
Using rack-cache 1.2
Using rack-test 0.6.2
Using hike 1.2.3
Using tilt 1.4.1
Using sprockets 2.2.2
Using actionpack 3.2.13
Using mime-types 1.23
Using polyglot 0.3.3
Using treetop 1.4.14
Using mail 2.5.4
Using actionmailer 3.2.13
Using arel 3.0.2
Using tzinfo 0.3.37
Using activerecord 3.2.13
Using activerecord-oracle_enhanced-adapter 1.4.2
Using activeresource 3.2.13
Using net-ldap 0.3.1
Using adauth 1.2.1
Using addressable 2.3.5
Using json 1.8.1
Using airbrake 3.1.12
Using rack-ssl 1.3.3
Using rdoc 3.12.2
Using thor 0.18.1
Using railties 3.2.13
Using jquery-rails 1.0.19
Using bundler 1.6.3
Using rails 3.2.13
Using best_in_place 2.1.0
Using bootstrap-sass 2.0.4.2
Using cancan 1.6.10
Using highline 1.6.19
Using net-ssh 2.6.7
Using net-scp 1.1.1
Using net-sftp 2.1.2
Using net-ssh-gateway 1.2.0
Using capistrano 2.12.0
Using mini_portile 0.5.1
Using nokogiri 1.6.0
Using xpath 2.0.0
Using capybara 2.1.0
Using ffi 1.9.0
Using childprocess 0.3.9
Using chronic 0.9.1
Using coderay 1.0.9
Using coffee-script-source 1.6.3
Using execjs 1.4.0
Using coffee-script 2.2.0
Using coffee-rails 3.2.2
Using composite_primary_keys 5.0.13
Using database_cleaner 0.7.2
Using diff-lcs 1.2.4
Using factory_girl 4.2.0
Using factory_girl_rails 4.2.1
Using sass 3.2.12
Using sass-rails 3.2.6
Using font-awesome-sass-rails 3.0.2.2
Using formatador 0.2.4
Using rb-fsevent 0.9.3
Using rb-inotify 0.9.0
Using rb-kqueue 0.2.0
Using listen 1.2.2
Using lumberjack 1.0.4
Using method_source 0.8.2
Using slop 3.4.6
Using pry 0.9.12.2
Using guard 1.8.2
Using rspec-core 2.14.4
Using rspec-expectations 2.14.0
Using rspec-mocks 2.14.2
Using rspec 2.14.1
Using guard-rspec 3.0.2
Using haml 4.0.3
Using haml-rails 0.4
Using iconv 1.0.3
Using jquery-scrollto-rails 1.4.2
Using jquery-ui-rails 4.0.3
Using jquery-ui-sass-rails 4.0.3.0
Using kaminari 0.14.1
Using launchy 2.3.0
Using libv8 3.11.8.17
Using quiet_assets 1.0.2
Using ref 1.0.5
Using rspec-rails 2.14.0

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

/usr/bin/ruby1.9.1 extconf.rb
checking for load library path...
LD_LIBRARY_PATH...
checking /usr/lib/oracle/12.1/client/lib... no
checking ld.so.conf... no
checking for cc... ok
checking for gcc... yes
checking for LP64... no
checking for sys/types.h... yes
checking for ruby header... ok
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/usr/bin/ruby1.9.1
--with-instant-client
--without-instant-client
/tmp/bundler20140624-4932-e7ymvw/ruby-oci8-2.1.5/gems/ruby-oci8-2.1.5/ext/oci8/oraconf.rb:889:in `get_home': RuntimeError (RuntimeError)
from /tmp/bundler20140624-4932-e7ymvw/ruby-oci8-2.1.5/gems/ruby-oci8-2.1.5/ext/oci8/oraconf.rb:705:in `initialize'
from /tmp/bundler20140624-4932-e7ymvw/ruby-oci8-2.1.5/gems/ruby-oci8-2.1.5/ext/oci8/oraconf.rb:320:in `new'
from /tmp/bundler20140624-4932-e7ymvw/ruby-oci8-2.1.5/gems/ruby-oci8-2.1.5/ext/oci8/oraconf.rb:320:in `get'
from extconf.rb:18:in `<main>'



Error Message:
Set the environment variable ORACLE_HOME if Oracle Full Client.
Append the path of Oracle client libraries to LD_LIBRARY_PATH if Oracle Instant Client.

Backtrace:
/tmp/bundler20140624-4932-e7ymvw/ruby-oci8-2.1.5/gems/ruby-oci8-2.1.5/ext/oci8/oraconf.rb:889:in `get_home'
/tmp/bundler20140624-4932-e7ymvw/ruby-oci8-2.1.5/gems/ruby-oci8-2.1.5/ext/oci8/oraconf.rb:705:in `initialize'
/tmp/bundler20140624-4932-e7ymvw/ruby-oci8-2.1.5/ gems/ruby-oci8-2.1.5/ext/oci8/oraconf.rb:320:in `new'
/tmp/bundler20140624-4932-e7ymvw/ruby-oci8-2.1.5/gems/ruby-oci8-2.1.5/ext/oci8/oraconf.rb:320:in `get'
extconf.rb:18:in `<main>'


Gem files will remain installed in /tmp/bundler20140624-4932-e7ymvw/ruby-oci8-2.1.5/gems/ruby-oci8-2.1.5 for inspection.
Results logged to /tmp/bundler20140624-4932-e7ymvw/ruby-oci8-2.1.5/gems/ruby-oci8-2.1.5/ext/oci8/gem_make.out
An error occurred while installing ruby-oci8 (2.1.5), and Bundler cannot
continue.
Make sure that
gem install ruby-oci8 -v '2.1.5'
succeeds before bundling.

Answer

In order to compile the native extension gem ruby-oci8, whcih is required for active record oracle adapter, it needs to know the path to the oracle client.

  #check the path of your Oracle instanant client install
 export LD_LIBRARY_PATH=/opt/oracle/instantclient:$LD_LIBRARY_PATH

 $ bundle install
Comments