Ashu Ashu - 6 months ago 39
PHP Question

Failed opening required 'System.php' (include_path='.;C:\php\pear') in D:\wamp\www\z

I am bit new in php. I Downloaded a wordpress and installed in my wamp. But the below error encountered.

Fatal error: require_once() [function.require]: Failed opening required 'System.php'
(include_path='.;C:\php\pear') in D:\wamp\www\fundwe\...


My Wamp is not installed in C drive. Instead it is in D Drive. Please please help me

Answer

In WAMPServer, the include_path is commented out, so you are getting the default version which is why it is pointing to include_path='.;C:\php\pear'

So you could try editing the php.ini file, using the wampserver menus to make sure you edit the correct file (\wamp\bin\php\{phpVersion}\bin\phpForApache.ini)

wampmanager->PHP->php.ini

And add a proper include path in place of the commented out one in there already

include_path=".;d:\wamp\bin\php\{yourPHPVersion}\pear"

Although I have an idea this is not related to PEAR at all.

You would probably be better of creating a Virtual Host for the Wordpress site to run in, then it will probably find the file its looking for in the theme folder.