Unknown94 Unknown94 - 10 months ago 137
R Question

"plotly" package not working in r

I am trying to use 'plotly' package in R to build graphs, but I am getting the following error:

package ‘ggplot2’ 2.1.0 is loaded, but > 2.1.0 is required by ‘plotly’
In addition: Warning message:
package ‘plotly’ was built under R version 3.2.5

I have tried installing 'ggplot2' and 'plotly' again and again, but the error still remains the same.

Any solutions for this? Thanks in advance.

Answer Source

Try updating everything. Use the installr package like so:

install.packages("installr")

library(installr)
updateR()

Then be sure that you update the packages when prompted to do so.